Searching txt.sour.is

Twts matching #ToS
Sort by: Newest, Oldest, Most Relevant

Major winemaker threatens to move business overseas if tax changes go through
The managing director of Taylors Wines in South Australia is threatening to move the business internationally in response to the federal government’s proposed tax changes. ⌘ Read more

⤋ Read More
↳ In-reply-to » @movq Thanks. I noticed the <updated> of the feed, too. But for some reason, some articles were suddenly marked as new.

Aha, yesterday’s newly added support for LC_TIME to render localized timestamps also broke the feed parsing with my LANG=de_DE.UTF-8 and LC_CTYPE=de_DE.UTF-8 environment. :-)

Atom feeds make use of RFC 3339 timestamps. They are first converted into RFC 882 timestamp representation, which is the one that RSS feeds use. However, this conversion now results in localized RFC 882 timestamps, which cannot be parsed into Unix timestamp numbers via curl_getdate(…). I bet that it doesn’t know about the localization at all and expects English month and weekday names. Looking at its docs, I reckon that function was selected because of its myriad of supported timestamp formats: https://curl.se/libcurl/c/curl_getdate.html RFC 3339 is not included, though, hence the transformation up front.

The intermediate Item objects in the parser domain use std::string for the timestamp representation. This isn’t all that silly, because Newsboat supports all sorts of different feed formats with different timestamp formats. These RFC 883 timestamps are centrally parsed into time_t.

Speaking of time: It’s time to go to bed after this late bug hunting fun. :-)

⤋ Read More

Darwin’s Middle Arm precinct could be roadblocked by endangered herb
The NT government is arguing its planned mega Middle Arm gas industry precinct will be needed to help shore up Australia’s future fuel and energy supplies — but it has just identified that a tiny endangered herb could be growing in the way. ⌘ Read more

⤋ Read More
↳ In-reply-to » @lyse (Do you want to be linked on that page? Do you want your name to be there at all? 🤔)

@movq@www.uninformativ.de I really like your style of writing, btw. It’s much calmer and less aggressive then mine. :-) When I turned my bullet points into paragraphs, I got a bit mad in the process.

Sure, feel free to include anything you want. Regarding citing, this is where twtxt falls short in my opinion. Especially with feed rotation, classic links die quickly. Message hashes only help so much. Nobody outside the twtxt universe knows how to deal with them. So, not perfect for inclusion on a web page. Linking to a thread or message on some yarnd instance might be the more user-friendly option. But the disadvantage is that it’s “just” a mirror, not the primary or original source. In all reality, this could be considered splitting hairs, though.

I should have probably written a proper article. That would have given me time to review the result more carefully, too. ;-) Perhaps that’s something for the future. But honestly, I’m not sure if I really want to waste my time and energy on that subject. So many other fun or useless things come to mind right away that I could do instead. 8-)

So, yeah, do whatever feels best to you. I don’t mind being cited or linked, but I also don’t mind not to be cited or not to be linked to. :-D Not a helpful answer, I know. Sorry. ;-) But anyway, thanks for asking, mate! I do appreciate it.

To finish my thought, linking to my frontpage is probably also useless, since I deliberatly do not have a table of contents there. In fact, my entire frontpage is rather silly.

⤋ Read More
↳ In-reply-to » I’ve started collecting reasons against AI usage here, so I don’t have to repeat myself all the time:

@lyse@lyse.isobeef.org Thanks! There are a few points in there that I’ll add to my list.

Your very first point is obviously crucial. “Writing code” is just the means to an end for many people and they don’t really care about it or like it, so they love AI. I had this in another draft (it refers to the other list I posted):

https://movq.de/v/614f14c3ef/ramble.txt

And this right here is so important:

simplicity is the real art and much harder to achieve.

Finding an elegant, simple solution is waaaaaaaaaaaaaaaaaay harder than anything else. And here’s the thing: I don’t get why nerds/techies don’t get “nerd-sniped” by this. A lot of people love building big stuff and then brag about being clever/competent because they were able to build that big thing – but once you realize that this approach is the lazy one, shouldn’t you make finding the elegant solution your goal? Doesn’t that give you more bragging rights?

(Am I being clear? Do you understand what I mean? 😅)

⤋ Read More
↳ In-reply-to » You didn't change your Atom feed by any chance yesterday or today, @movq? Not only do I have a metric shitton of "new" old items in my YouTube feeds, but also a bunch of your old articles are shown as new.

@lyse@lyse.isobeef.org Uhhh, yes, I have one single script to build the website and I ran that while writing that noai.html page. Apart from the global updated field in my feeds (that one got changed), everything else should be stable, though.

Maybe this helps narrow things down?

Image

⤋ Read More
↳ In-reply-to » I’ve started collecting reasons against AI usage here, so I don’t have to repeat myself all the time:

Of course, @movq@www.uninformativ.de! Most of my points are also included in your list.

First of all, programming is what I really do enjoy the most. So, it doesn’t make any sense at all to not do this anymore. “But you could use your now free time to do something much cooler and more valuable!”, others might reply. Fuck no, I don’t want to waste my time with other shit that doesn’t fulfill me, why on earth would I want to do that?

All this hallucination reduces quality badly. In my experience, it’s also happening much more rapidly than I expected. Even though developers are still supposed to own and understand whatever has been generated under their name and even be responsible for that, the sad reality is that teammates often blindly trust the AI output. “But I asked the AI and it told me that $this was impossible”, “I’ve no idea either, but the AI just generated it” are responses I get more often. What really makes my angry is when I point out a flaw and suggest an alternative and this is the reaction. It happened several times that just trying it out and seeing it clearly work to proof my point only took me half a minute, but people still did something handwavy else instead.

The learning effect is drastically reduced. The more time I spend on a topic, the better the odds that whatever I learned actually makes it over into long-term memory. It’s like if a collegue just says “do it like that” or “this solves your problem”, but neither explains the why or how. Somehow, people are still convinced that it’s a completely different story when you replace the human counterpart with a computer program in this equation.

Skills are unlearned. It’s like with automation in general, just much worse. You end up in a state where you’ve no clue how anything works under the hood or how to actually find out important information that are needed to solve your problem. You’re screwed when a process breaks out of the blue. Even though it can become also rather terrible, with classical automation you’re typically still be able to decipher how exactly the thing was supposed to do something.

The energy consumption is sooo high, I absolutely do not want to be a part in burning down our planet. I’m sure I find (and probably have long found without knowing) other ways to contribute to worsen our climate crisis.

The scraper part is already covered in detail in your list. :-)

I’m convinced that license and copyright violations are only played down or even refused entirely because companies want to make big money quickly. With the work of others of course. Their double standards are obvious, they still try to actively keep their own stuff secret and out of any training sets. At most for internal use only. Virtually noone in charge is interested in good long-term solutions. Short-term for the win, when disaster eventually strikes, the causers are long gone, the responsibilities in other hands.

Vendor lock-in is something that lots of folks are only realizing very slowly. It’s completely crazy to me. This drug dealer routine should be well-known by now. It’s fucking everywhere. Yet, people are always surprised when they found themselves caught in it.

Adding new AI stuff only increases complexity. But complexity is the enemy that everybody should fear and reduce as much as possible. Of course, this is not limited to AI at all. And everywhere I look around, people in charge looooove to make things way more complicated than they ever need to be. Yet, simplicity is the real art and much harder to achieve.

I don’t understand why we have to go back full force to the ambiguity of natural languages. This alone should be more than enough to realize what a stupid idea all that is. Linked to that is that the “instruction set” is interpreted differently with newer model versions. I mean, is has to be. Why else would somebody want to upgrade in the first place than to get more Powerful™ Features™?

Some people argue that with AI the democratization is empowered. However, in my view, the exact opposite is the case. Models are getting so large that you can basically not run them locally or even train them. So, you have to rely on whatever the vendor offers you and runs for you. In the end, this only gives the owners more power, the multi billionaires. Not exactly what I understand by democratization.

Finally, technology assessments are missing completely. Or they are faked such that mostly only the (questionable) benefits are listed. But all the negative impact is just ignored.

Let’s keep some popcorn around for when this all explodes. :-)

⤋ Read More

The Pentagon Knew Enemies Could Track Troops’ Phones for Years. Now They Are
The US military has long known that cheap fixes could stop location data from exposing its troops. It adopted almost none—and now says adversaries are using the data to target soldiers during a war. ⌘ Read more

⤋ Read More

These Ebola Researchers Are Stuck in US Due to Trump’s Funding Cuts
The Centers for Research in Emerging Infectious Diseases were launched during the Covid-19 pandemic. The group lost its funding under Trump in part due to conspiracy theories. ⌘ Read more

⤋ Read More

1girl ai_generated ass bigass breasts chel chel(the_road_to_el_dorado) dreamworks fundoshi huge_ass pixel_art the_road_to_el_dorado
1girl ai_generated ass big_ass breasts chel chel_(the_road_to_el_dorado) dreamworks fundoshi huge_ass pixel_art the_road_to_el_dorado ⌘ Read more

⤋ Read More

1girl ai_generated ass bigass breasts chel chel(the_road_to_el_dorado) dreamworks huge_ass loincloth pixel_art the_road_to_el_dorado
1girl ai_generated ass big_ass breasts chel chel_(the_road_to_el_dorado) dreamworks huge_ass loincloth pixel_art the_road_to_el_dorado ⌘ Read more

⤋ Read More

1girl ai_generated ass bigass breasts chel chel(the_road_to_el_dorado) dreamworks fundoshi huge_ass loincloth pixel_art the_road_to_el_dorado
1girl ai_generated ass big_ass breasts chel chel_(the_road_to_el_dorado) dreamworks fundoshi huge_ass loincloth pixel_art the_road_to_el_dorado ⌘ Read more

⤋ Read More

1girl ai_generated ass bigass breasts chel chel(the_road_to_el_dorado) dreamworks fundoshi huge_ass loincloth pixel_art the_road_to_el_dorado
1girl ai_generated ass big_ass breasts chel chel_(the_road_to_el_dorado) dreamworks fundoshi huge_ass loincloth pixel_art the_road_to_el_dorado ⌘ Read more

⤋ Read More

1girl ai_generated ass bigass breasts chel chel(the_road_to_el_dorado) dreamworks fundoshi huge_ass loincloth pixel_art the_road_to_el_dorado
1girl ai_generated ass big_ass breasts chel chel_(the_road_to_el_dorado) dreamworks fundoshi huge_ass loincloth pixel_art the_road_to_el_dorado ⌘ Read more

⤋ Read More

Over there, on the othernet, I just stumbled upon the question:

When talking to yourself in your head, do you use “I”, “you”, or “we”?

As for me, I say “we” - in regular situations. But if I fuck up, it’s “you”. 😞👈

⤋ Read More

Illinois Lawmakers Just Passed America’s Strongest AI Safety Bill
The bill requires companies like OpenAI, Anthropic, and Google to have third parties confirm they’re following safety standards. Illinois Governor JB Pritzker says he’ll sign. ⌘ Read more

⤋ Read More

Google Security Engineer Arrested in Million-Dollar Polymarket Trading Scheme
According to federal prosecutors, Michele Spagnuolo made more than $1 million on the prediction market platform using confidential information about Google Search traffic. ⌘ Read more

⤋ Read More
↳ In-reply-to » By the way, did you know that I have a five month notice period? Starting next year, it’ll be six months. Germany is the opposite of “hire and fire”, but it applies to both parties.

@lyse@lyse.isobeef.org Yeah, I’ve heard of that option (“Aufhebungsvertrag”). I guess the real challenge will be finding something else that isn’t just as silly.

And on the bright side, you don’t even have to hand over anything.

They actually say that with a straight face. (Did I mention that already?) “The age of maintainership is over. Anyone can now contribute to any project at any time.”

⤋ Read More
↳ In-reply-to » By the way, did you know that I have a five month notice period? Starting next year, it’ll be six months. Germany is the opposite of “hire and fire”, but it applies to both parties.

@movq@www.uninformativ.de If you really like to, you can try to negotiate with your employer that you can leave earlier. At least some mates were successful in that. I mean, it’s also in the company’s interest to not have to pay someone who has already mentally resigned long ago.

And on the bright side, you don’t even have to hand over anything. Your boss doesn’t have to look for a successor, so they can just let you go even sooner. This AI shit will simply continue whatever you did, no problem!!

It’s so crazy. I should probably also look for something else. :-(

⤋ Read More

The State Department Really Doesn’t Want to Talk About the Office of Remigration
The office was created a year ago and seemingly named for a far-right European plan to expel minorities and immigrants from Western nations. It now works, a source says, with little to no oversight. ⌘ Read more

⤋ Read More
↳ In-reply-to » @prologic There is nothing I can do – except quit. The company explicitly wants it that way.

By the way, did you know that I have a five month notice period? Starting next year, it’ll be six months. Germany is the opposite of “hire and fire”, but it applies to both parties.

⤋ Read More

Department of Labor Tells Employees to Report Anyone Prioritizing DEI
The email instructs workers to report behavior that predates Donald Trump’s second inauguration. One employee tells WIRED it felt like a “reminder to narc on your coworkers.” ⌘ Read more

⤋ Read More

Show HN: Posthorn, self-hosted mail without the mail server
Introducing Posthorn, a self hosted email gateway. One docker container (or Go binary) between every self hosted app on your VPS and your transactional email provider. Set up Posthorn once, point your apps to it, done.

I was trying to deploy Ghost on a DigitalOcean droplet and found that DO and many different VPS services have started to block the default SMTP ports to try to combat the various types of abuse they get. To actually configure my app, I had to hack to … ⌘ Read more

⤋ Read More

Launch HN: Minicor (YC P26) – Windows desktop automations at scale
Hey we’re Faiz and Saheed and we built Minicor so AI companies who need to integrate to desktop systems with no API can quickly build scalable desktop RPAs. Demo: https://www.youtube.com/watch?v=MD0GHZIJ1cw

We were working on non-RPA integrations when a customer promised to sign a deal in 2 days if we could unblock a sale of theirs that involved integrating with a clinic’s Windows based medical record system. We didn’t know it at … ⌘ Read more

⤋ Read More

The US Can Put People on the Moon. Why Can’t It Get Iranians Online?
Jason Rezaian spent years reporting from Iran before being imprisoned by the regime. He says internet access is key to transforming the country—if only the US government would do something about it. ⌘ Read more

⤋ Read More